Tmotor Phase resistance out of range

Hi All,

I am trying to get a TMotor R150 working with the Odrive Pro. However I am getting issues with the phase resistance calibration (Phase_Resistance_Out_Of_Range). The below are the specs of the motor, which I have written to the Odrive.

I have read in previous posts that if the phase resistance is above 1 Ohm it can cause issues but this is a very old post. Is this still a known issue? The Tmotor is ~1.5 Ohm

I have also carefully checked all my connections and measured the resistance from the soldered phase pads on the board to confirm it is a good connection. I have tried raising the calibration voltage up to 10v, and increased the calibration current incrementally up to 15A. I have tested the Odrive with a smaller 700kv motor and it calibrates fine. I have also tried a second Tmotor of the same specs and get the same result. I am using a large 16.8v L-ION battery pack which has more than enough current capacity. I am a bit stuck on what to try next, any help would be greatly appreciated.

Looking for some guidance on how to get this working. Thanks for you help. Thank you!



Hi there,

The phase resistance times calibration current must be smaller than the calibration voltage.

Maybe try 10V calibration voltage and 5A calibration current? That should work.

Thank you Solomondg,

I lowered it to the values you mentioned and the resistance calibration was successful but then phase inductance was out of range.

I ended up having success with 5v and 1A as the calibration settings.

Thanks for your help.