Error backing up Odrive

I’m trying to backup my odrive pro with the command odrivetool backup-config backup.json. When I run it I get this error.

Saving configuration to C:\Users\user\AppData\Local\Temp\odrive-config-397835643431.json...
KeyError                                  Traceback (most recent call last)
File ~\anaconda3\Scripts\odrivetool:251
    249     print("Waiting for ODrive...")
    250     my_odrive = odrive.find_any(path=args.path, serial_number=args.serial_number)
--> 251     backup_config_ui(my_odrive, args.file, logger)
    253 elif args.command == 'restore-config':
    254     from odrive.legacy_config import restore_config_ui

File ~\anaconda3\Lib\site-packages\odrive\, in backup_config_ui(device, filename, logger)
     92     if not yes_no_prompt("The file {} already exists. Do you want to override it?".format(filename), True):
     93         raise OperationAbortedException()
---> 95 data = backup_config(device)
     96 with open(filename, 'w') as file:
     97     json.dump(data, file, indent=2)

File ~\anaconda3\Lib\site-packages\odrive\, in backup_config(device)
     65 val =
     66 if isinstance(val, fibre.libfibre.RemoteObject):
---> 67     val = prop_dict[val]
     68     print("path:", val)
     69 result[k] = val

KeyError: exchange(obj: object_ref, newval: float) -> oldval: float
read(obj: object_ref) -> value: float

I’m running odrivetool through anaconda on a windows 11 machine.

Oh, what a coincidence, I justed posted in V3 section with the same problem. Wonder if there was a Python update that broke odrivetool?

1 Like

Did you have the same error as well?

Yes, my post here just this evening

They are looking into it on discord

I was able to get mine to backup by downgrading to a different version of odrivetool. What version are you using?