Odrivetool "Could not open USB device"

Hello,

Completely new to the odrive scene so please go easy!

Previously, I had successfully used the odrivetool with my 24V odrive v3.6 to drive a motor with no issue.

I have recently moved to a new PC and have followed the installation processes as per the documentation. Now, when running the odrivetool, I cannot connect to the device? When launching the odrive tool, the prompt states:

(base) C:\>odrivetool
ODrive control utility v0.5.2.post0
Website: https://odriverobotics.com/
Docs: https://docs.odriverobotics.com/
Forums: https://discourse.odriverobotics.com/
Discord: https://discord.gg/k3ZZ3mS
Github: https://github.com/madcowswe/ODrive/

Please connect your ODrive.
You can also type help() or quit().

In [1]: e[91;1m11:52:53.786864900 [USB] Could not open USB device: -5e[0m
e[91;1m11:52:54.803066100 [USB] Could not open USB device: -5e[0m
e[91;1m11:52:55.817998200 [USB] Could not open USB device: -5e[0m
e[91;1m11:52:56.834118400 [USB] Could not open USB device: -5e[0m
e[91;1m11:52:57.847404300 [USB] Could not open USB device: -5e[0m 

The only thing I can see is wrong is that on the device manager, it thinks the device is a formlabs printer!?

image

Any help would be greatly appreciated,

Thanks
Dan

Same here with dan, 56V odrive v3.6 exact same output from anaconda and except driver shows its a WinUSB Device.

edit: Version of firmware on odrive is 0.5.1, repeating this with ver 0.5.2 results in the odrive not being detected at all by odrivetool

If you could both show your Zadig screenshots for the Native interface and the CDC interface that will help.

Note that the instructions about the Zadig utility have been removed from the docs because odrivetool should work without driver setup now.

However unfortunately apparently the Formlabs driver grabs more devices than it should. I’d be interested in what exactly it grabs. Can you follow the instructions in this post to find Formlabs’ “.inf” file? When you find it then please paste or upload it here.

Once that’s done, you can override the driver with the Zadig utility by setting the ODrive Native Interface’s driver to “libusb-win32”.

Here’s a screenshot of the device drivers and zadig


![Zadig Odrive|690x308](upload://pTzJCZq5i0L8geC1p9PLyq2UroV.pn
edit: The Odrive Native Interface just popped up in Zadig and replacing it with the libusb got it up and running for v0.5.1 will try for v0.5.2

1 Like

Upgrading to 0.5.2 with odrivetool dfu returns an error,
RuntimeError: An error occured. Device Status: (0, 2, 0, 0)
Trying with STM32 Cube Programmer to flash it with the 0.5.2 hex file causes the ODrive Native Interface to not appear at all in Zadig to flash it as libusb, not really sure how to upgrade to 0.5.2.
I’ve seen the same error mentioned in the 0.5.2 release thread by rob but wasn’t clear on how he resolved this issue. Hopefully someone can help.

Is this an odrive purchased from odriverobotics.com?

Did you find a solution for this?

No. My problem:
(base) C:\Users\Kaj.AAU117352>odrivetool -v
ODrive control utility v0.5.4

Please connect your ODrive.
You can also type help() or quit().

In [1]: ←[91;1m16:51:28.276128200 [USB] Could not open USB device: -5←[0m
←[91;1m16:51:29.364662000 [USB] Could not open USB device: -5←[0m
USB: Win Usb Device

Also in Python:

device = usb.core.find()
Traceback (most recent call last):
File “”, line 1, in
File “C:\Users\Kaj.AAU117352\anaconda3\lib\site-packages\usb\core.py”, line 1309, in find
raise NoBackendError(‘No backend available’)
usb.core.NoBackendError: No backend available

Please use Zadig on Windows to set the Native Interface to WinUSB

1 Like

Many thanks. I managed to do it.

1 Like

I had the same Issue, what worked for me was:
with Zadig → options-> List all devices
Odrive 3.6 CDC interface install USB Serial(CDC)
ODrive 3.6 Native Interface install libusb-win32 (v1.2.6.0)

Hope it helps

4 Likes

I had been having the same issue, and this fixed it. Thanks!

Also in case it matters, I’m running Windows 11 and using an ODESC3.6 (sorry!)

1 Like

Same for me, in generall this forum is a great way to fix issues with an odrive.

Actually, I ran into an issue the next day (maybe next power cycle) where I could no longer see the odrive at all with odrivetool or zadig. I did manage to see it with the DFU switch, but I am having issues with firmware. I will update with more details or start a new thread later today.

I hope that this isn’t too late, but I also ran into this problem, and the fix is stupid simple, because the cause is also stupid and simple…

I had the D5312S motor, and it turns out I had over-screwed the mounting fasteners, and that they were shorting out the windings (oops!)… So yeah, backing it off a bit instantly fixed the problem, I am very sketched out and I think I’ll have to coat the damaged portion with some conformal coating.

3D printed test fixture: if anyone wants the STL or the solidworks model feel free to ask!