Error_brake_resistor


#1

When I try to increase the vel_limit to 210000 to 250000 the motor coast to a stop and I get the following errors

ERROR_INVALID_STATE
ERROR_BRAKE_RESISTOR_DISARMED
ERROR_MOTOR_DISARMED

the odrv0.config.brake_resistance is 2.0

Is there any way to stop this from happening and to increase the speed?
Thank you in advance for your help.


#2

Hi,
I’m not completely sure, but I think you are saturating the brake resistor. What bus voltage are you running, what settings for current_lim, and what motors are you using?

We will be adding better error messages for brake resistor saturation, it’s already on the devel branch, and should be available soon.


#3

@madcowswe I get this same issue, what do you need for me to do to help you solve this?
I posted here: ERRORS: Axis: 0x30 Encoder: 0x0 Motor: 0x40
but will happily close that thread to continue this one.

I get the following errors when I spin the motor up. Once it hits a specific point, it trips and coasts to a stop. Then the errors for BRAKE_RESISTOR_DISARMED cannot be cleared.

Why is this happening and what can I do to stop it… am I going to fast?
motor.config.current_lim = 50.0
controller.config.vel_limit = 1000000.0

** I am new to this, so please bare with me on this :slight_smile:

Axis: 0x30 Encoder: 0x0 Motor: 0x40
[ axis ] => ERROR_BRAKE_RESISTOR_DISARMED : the brake resistor was unexpectedly disarmed
[ axis ] => ERROR_MOTOR_DISARMED : the motor was unexpectedly disarmed
[ motor ] => ERROR_BRAKE_CURRENT_OUT_OF_RANGE :


#4

This is the latest information on this problem.

It’s becoming quite a problem for the development I’m involved in.


#5

@Neil_FV Thanks for the info.

Are there any “Best” settings you have found for this. I am fine limiting my project for now while this is being solved. This is my first robotics project and I am way over my head here on the electronics side. Any help is appreciated.


#6

I’m using a standard hobbyking 149kv motor, 46v and a limit of 75 amps

should I put another resistor in series?


#7

… anybody have any ideas on this?


#8

I posted a solution here: